Loading Sim files to eclipse shows two errors

Home Forums PeerfactSim Forum Loading Sim files to eclipse shows two errors

This topic contains 8 replies, has 1 voice, and was last updated by  Shreyas Sarvothama 5 years, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #820

    Shreyas Sarvothama

    Hi,

    First, Thank you for providing us a free p2p simulator.

    I am trying to learn peerfactsim and I have seen your demonstration video.

    When I goto download page on peerfact.org and click on this link. It says 502 server error.
    So I downloaded peerfactsimkom main community updated on oct 9 2012 2:30AM
    I also downloaded the required XML file.

    By following the steps in the video I am getting errors.

    I copied the extracted files to the eclipse workspace. It said two errors.
    I selected GUI runner and try to run the file.. the below is a snapshot of the error when tried to run.

    Please help!

    Thanks in advance.

    #821

    Matthias Feldotto

    Hey,

    the version you used is not the current one. Please try it again with the newest version. You’ll find it on Google code: https://code.google.com/p/peerfactsimkom-community/source/checkout

    Regards,
    Matthias

    #822

    Shreyas Sarvothama

    Thank you for your reply Matthias.

    As I mentioned in my previous post… i am not able to download it….

    here is the screen shot for your kind perusal:

    #823

    Matthias Feldotto

    Hey,
    the automatic zip generation at Google Code is sadly not working at the moment, we don’t know why. Therefore the link is broken. Could you please use a Git client to download it directly from the repository as it is explained at the Checkout page at Google Code: https://code.google.com/p/peerfactsimkom-community/source/checkout

    Thanks!

    #824

    Shreyas Sarvothama

    Hi,

    Using the files downloaded from git… here is the error in eclipse when i try to build:

    Project ‘peerfact’ is targeting a 1.6 runtime, but is compiled against ‘C:Program Files/Java/jre7/lib/rt.jar’ (from the container ‘JRE System Library [JavaSE-1.6]’) which requires a 1.7 runtime

    #825

    Matthias Feldotto

    Hi,

    the currrent version of the simulator is targeting a 1.6 runtime, because it is the most frequently used version at the moment. You have to configure your Eclipse, that it compiles against the 1.6 runtime (which is also possible with a newer runtime). Otherwise you can additionally install a 1.6 runtime on your system.

    #826

    Shreyas Sarvothama

    Hi,

    Many thanks for the reply. It compiled and worked.

    Now the problem is after running the simulation, there are no files getting loaded into output folder. I do not understand what the issue is now? Simulation runs successfully with no errors. But nothing gets loaded into the output folder.

    Please Help!

    Thanks in advance.

    Kind Regards,
    Shreyas

    #828

    Shreyas Sarvothama

    here is the screenshot of successfull simulation but no result in output folder.

    On Sunday, 3 March 2013 21:22:28 UTC+5:30, Shreyas Sarvothama wrote:

    Hi,

    First, Thank you for providing us a free p2p simulator.

    I am trying to learn peerfactsim and I have seen your demonstration video.

    When I goto download page on peerfact.org and click on this link. It says 502 server error.
    So I downloaded peerfactsimkom main community updated on oct 9 2012 2:30AM
    I also downloaded the required XML file.

    By following the steps in the video I am getting errors.

    I copied the extracted files to the eclipse workspace. It said two errors.
    I selected GUI runner and try to run the file.. the below is a snapshot of the error when tried to run.

    Please help!

    Thanks in advance.

    #829

    Shreyas Sarvothama

    screenshot of successful simulation but with no files in output folder

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed