Not able to open anything using GUI Runner

Home Forums PeerfactSim Forum Not able to open anything using GUI Runner

  • This topic has 4 replies, 1 voice, and was last updated 7 years ago by Chintan Parekh.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #882
    Chintan Parekh
    Guest

    Hi,

    I am constantly getting this error whenever i open the GUIRunner and click on anything(For example Chord.xml)…I have tried this with the old version and it worked fine but the new version gives me this error.

    de.tud.kom.p2psim.impl.util.guirunner.impl.ConfigFile$ConfigFileException: Cannot parse document. The root element ‘Configuration’ is missing

    Can you please suggest me what to do?

    Thanks..

    #883
    Matthias Feldotto
    Guest

    Hey,

    it seems that you have not opened a correct configuration file. To verify this, can you please give me the whole path of the file you tried to open?

    I suggest that you opened a wrong file. Since the newest version we work with includes to avoid redundances in the configuration files. As consequence there are several confguration files (in the folder includes) which cannot be opened by their own, but are used in other files. The default configuration file to use is the config/dht.xml.

    I hope that helps you!
    Matthias

    #884
    Chintan Parekh
    Guest

    Hi,

    config/dht.xml is working fine.

    However none of the others are working. For example if I open config/includes/***(any file in this folder) then it throws and exception(this exception is thrown even on selecting the file and also when I open the GUIRunner)

    #885
    Matthias Feldotto
    Guest

    As already said, all files in config/includes cannot be openend on their own, they are only used by other configuration files.

    Some further working configuration files can be found in the other folders config/visualization and config/scenarios.

    #886
    Chintan Parekh
    Guest

    Ah..ok..Got it..!..Everything clear now..!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Comments are closed.